Requestor Address Not Showing on Enterprise Forms MLC

Description of Issue

The requestor address is typed in on the define screen but not showing on the ReadyForms version of the MLC. 

Context
  • MA Tax

  • Municipal Lien Certificates (tmalienc)

  • MLCs 

  • ReadyForms

  • Requestor Address

Cause

The address is typed into the wrong box. 

Resolution
  1. Navigate to the Municipal Lien Certificates program either by searching or using the following path: Property Revenues > Property Tax Billing > Northeast > Massachusetts > Collection Processing > Municipal Lien Certificates 

  2. Click Single Define. 

  3. Enter the Parcel ID. 

  4. Type Name 1 and Name 2 on the first two lines of the account fields. If there is no Name 2 on the address, leave line 2 blank. 

  5. Type Address Line 1 and Address Line 2 on the third and fourth lines of the account fields. If there is no Address Line 2, leave line four blank. 

  6. Enter the City or Town, State, and Zip Code in the three fields on the fifth line. 

  7. Generate a new certificate number by clicking the Plus 1 button next to the Next certificate no field. 

  8. Make all other desired selections using the field descriptions from the help menu for guidance. The help menu can be accessed by clicking the Question Mark in the upper right corner and then selecting Help. 

  9. Click Accept. 

  10. Click ReadyForms.

Additional Information
  • This should not be an issue if a Customer ID is entered into the Account field. The information will populate automatically in the correct fields.  

  • If further assistance is required, please contact Northeast Tax Support. 

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