AR API creating payments in individual batches

Description of Issue

Each individual payment is being created by the AR API in a single, separate batch

Context
  • Accounts Receivable
  • API
  • Batches
Cause

The AR API payment calls are not using the same username and/or date combination or only a single AR API payment call was made. 

Resolution

 Payments for a single date and username combination should be added to the same batch by the API. All payments are recorded in batches. A batch of payments is a group of receipts entered by one clerk or for one receipt station. There is usually one batch per clerk or station per day, though a new batch per clerk or station may be open while an earlier batch is in the review stage. A batch is automatically located or created for payment processing. The combination of username and date are used to group records. When a payment is received through the API, the application checks to see if a batch exists for the username/date combination. If it does, then the payment will be added to the existing batch; if not, then a new batch will be created.

After all the payments are entered into a batch, the batch should be closed by the integrating vendor by using the POST /api/AR/v1/batches/close API call. 

The batch must be closed to complete it and advance it into an In Review status if the WSUSER AR Batch Release permissions are set to In Review or Workflow if PEA Workflow is used. If the WSUSER's AR Batch Release permission is set to Released and PEA Workflow is not in use, then the batch should advance directly to life cycle step 30 when the batch is closed and then the batch can be posted from Payments Journal. Specific instructions for how to do this can be found here: How to post a payment batch in Payments Journal

Additional Information