RVA blank email message passed to workflow routine

Description of Issue

Update error Blank email message passed to WF engine routine. Contact Software Support.

Context
  • Munis
  • 2019.1
  • Payment Reversals
  • Workflow
  • RVA Workflow Approval
Cause

Sites are reporting an error for an approver in Tyler Hub stating Update error Blank email message passed to WF engine routine. Contact Software Support. 

Support has now replicated this error internally and the issue is being reviewed and researched within Development for a resolution. It seems to be related when RVA is setup with more than one step and each of those steps having a specific approver. This article will be updated as more information becomes available. 

Resolution

To avoid the error site's have been getting creative with their Business Rules. The largest one is only having a single RVA Step/Approver. This removes the multi-step/approver scenario and should bypass the error. Other sites are testing setting the RVA as Notify for the first step and then an RVA as Approve for the second step, although this has not been tested/confirmed by support.

If you have an RVA Workflow Approval with the above symptoms and have already submitted it but need the batch to process, please submit a case with Munis Support as the current workaround is to have support update the Workflow Status/Comment to Approved and advance the LifeCycleStep of the batch so sites can process the batches accordingly. 


Accounts Receivable Development is now researching this issue to begin to look to resolve it. 

Additional Information