No Options Appear When Editing Payments Users

Description of Issue

In Payments Administrative Tools > Permissions > User permissions, if you click edit on a user, a prompt appears saying Add permissions for (name)? If you click Add, nothing happens. 

Context
  • Payments

  • Portico

  • Admin Center

Cause

No departments have been added to the program. 

Resolution
  1. Go to Administrative Tools > Permissions > Departments.

  2. Add a Department. Name and description as desired. 

  3. Assign a Payment Type to this department. 

    1. Note: Multiple departments can be created, but once a Payment Type is assigned to a department, it cannot be assigned to another. 

  4. Save.

  5. Return to Administrative Tools > Permissions > User permissions. 

  6. Click Edit on any user. 

You can now set a Role to a user, split between as many departments as have been created. 

Additional Information

Payments comes with four Roles by default: Admin, Limited, View Only, and None. More Roles can be added based on site preference. A user can have Admin role for some departments and view only for others, for example, depending on how many departments were created.Â