Rules Engine policy not converting time on Saturday

Description of Issue

The client created a rules engine to convert time worked on Saturday but it did not work as intended. No hours were converted after assigning it to a rules engine configuration.

Context
  • Time & Attendance

  • ExecuTime

  • Rules Engine

Cause

The rules engine was incorrectly written. Under the comparison the first dropdown was set to == and then the pay code was entered in the next box. Instead of the pay code it should have said true

Resolution
  1. Login to Time & Attendance with Admin access

  2. Click System Admin

  3. Click Policies and Rules engin

  4. Click Rules Engine

  5. Click Individual Rules

  6. Click the Edit Pencil Icon for the rule

  7. Under Rules select the 2nd drop down and select Saturday Transaction

  8. Under Comparison select == and the box set it to true

  9. under Then select first drop down to Set pay code to Name and in the box Pay code type the pay code you want to convert the time to.

  10. Click Save

Additional Information