MarkPurgableDocuments failure messages in TCM Message Manager
Description of Issue
In the message manager in the TCM Full Client, repeating failed messages in the message manager are appearing stating:
Job monitor.system.cm.MarkPurgableDocuments: Start Mark Purgable Documents on failed on Munis-TCM, query failed, reading table=Job, column-JobObject, row info: (JobId: system.cm.MarkPurgableDocuments...
Context
- Tyler Content Manager
- TCM
Cause
In previous TCM Versions, the MarkPurgableDocuments job was created with a typo and has since been replaced with MarkPurgeableDocuments. When the new job was created, the old one was not deleted.
Resolution
Delete the misspelled job in the TCM Full Client:
- Login to the TCM Full Client. If assistance is needed with this, please refer to How to Access and Launch the TCM Full Client.
- Click on the Job Manager in the command ribbon (ie, the clock).
- Locate and click once on the MarkPurgableDocuments job.
- Click the Delete icon (this sets the job to run never).
- Click the Delete icon a second time to completely delete the job from the manager.
- Switch to the Message Manager (ie, the flag in the command ribbon) and delete any messages related to MarkPurga.
Additional Information