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Prerequisites Check Failed in Tyler Deploy

Prerequisites Check Failed in Tyler Deploy

Description of Issue

Prerequisites check failed when deployed with the following error message:

The deployment failed because one or more steps failed. Please see the deployment log for details. 

Context
  • Tyler Deploy

  • Prerequisites

  • Tentacle

  • Service

  • Server Health Check

Cause

Issue is due to the Tentacle service on the server being offline. Checking the server connection health will confirm if Deploy can talk to the Tentacle.

Resolution

The following are the steps to verify and restart the Tentacle service:

For Onprem Clients:

  1.  In Tyler Deploy, select Infrastructure Management from the menu on the left-hand side

  2. Select the Server you are attempting to deploy to and click the Check Health button and wait for it to finish

  3. If the check states that it failed, the Tentacle service is offline and will need to be restarted

  4. Connect to the server in question and in the Search bar in the bottom left of the screen, type Tentacle and select Octopus Tentacle Manager

    1. A prompt will appear asking "If you want to allow this app to make changes to your device?", select Yes

  5. In the Tentacle Manager under the Tentacle Name, if the Status is set to Stopped, click the Start Service on the top right that's under the Add New Tentacle button

  6. Back in Tyler Deploy, repeat step 2

  7. If the health shows green, the deployment of prerequisites will no longer fail.

  8. If it still shows red or is failing, Please contact TSM Support through the Support Portal

For Hosted Clients:

Please contact TSM Support through the Support Portal

Additional Information