TouchTime III Screen is Black

Description of Issue

TouchTime in Time and Attendance Kiosk going black

Context
  • Executime

  • Time and Attendance

  • TouchTime clocks

Cause

The clocks had an outdated EmulatorService.jar file

Resolution

Update the clocks with the jar files compatible with the installed Executime version.

  1. Locate the TFTP utility in Drive:\Instance\ClockPolling\tftpd64

  2. Launch the Tftp utility

  3. Select Tftp Client tab

  4. Populate Host field with IP address of target clock

  5. Populate Local File field by clicking the ellipse button, navigating, and selecting the EmulatorService.jar file

  6. Populate Remote file field with \ramdisk\root\EmulatorService.jar in the Remote file field

  7. Click Put

  8. Wait for transfer to complete

  9. Click OK on success message

Additional Information

Hosted client will need to create a case with TSMTA for firmware files. The App and firmware reside in the below path on the application server:

Drive:\Instance\System\Timeclock\Touchtime

Drive\Instance\System\Timeclock\firmware


The tounchtime file is the only file that need to be renamed before being placed on the clock. The file names will be as follow:

EmulatorService.jar

Emulator.jar

Classes.jar

App.jar