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Bills not showing in CSS after SaaS Flip
Bills not showing in CSS after SaaS Flip
Description of Issue
After switching from on premises hosting to SaaS hosting, commonly referred to as a SaaS Flip, no bills are showing in Citizen Self Service (CSS).Ā
Context
- Enterprise ERP
- Citizen Self Service
- CSS
- SaaS Flip
- Accounts Receivable
- Bills
Cause
There are many potential causes for this issue. Known causes include:Ā
- The Web User was set to Public Access Only.Ā
- The Web User's AR Code restrictions need to be reset.Ā
- The Web User is missing a required Accounts Receivable Attribute.Ā
Resolution
- Navigate to the User Attributes program either by searching or via the following path:Ā System Administration > Security > User Attributes
- ClickĀ Search.Ā
- EnterĀ *web in theĀ User ID field.Ā
- ClickĀ Accept.Ā
- If multiple Users return, use theĀ arrows at the bottom of the screen to navigate between them until the XXXXweb user is found. (TheĀ XXXX will be a four digit number that is the unique identifier for the site.)
- Select the Effective PermissionsĀ tab.Ā
- Click theĀ Filter button at the bottom of the page.Ā
- Select System / Internal as theĀ ProductĀ andĀ System Administration as theĀ Module.Ā
- ClickĀ Go.Ā
- SCROLL and find theĀ Restrict to 'Public Access' use only permission. Make sure theĀ Value isĀ No.Ā
- If the value is Yes, then click Restrict to 'Public Access' use only and then highlight theĀ Role assigning the Value of Yes and then click Edit Role.
- SelectĀ Update.
- Uncheck the box forĀ Restrict to 'Public Access' use only.
- ClickĀ Back.Ā
- If more Roles assign the value of Yes, then repeat steps a-e for each Role as necessary.Ā
- Note: It is recommended that the XXXXweb user have a single Role created just for that user. This is usually titled the WSUSERROLE. If the XXXXweb user has Roles assigned to it that are also assigned to other users, please be aware that a Role update will affect all users with that Role.
- Next, reset the AR Code access. To start this process, select the Filter button at the bottom of the page again.Ā
- SwitchĀ Product toĀ Revenue Systems andĀ Module toĀ Accounts Receivable.
- Select the Data Access tab.
- Double click on theĀ AR code access category.Ā
- Select theĀ Role granting AR code access.Ā
- ClickĀ Edit Role.
- SCROLL down to theĀ Data Access section and select theĀ Folder next to AR code access.
- If it is set toĀ Full then, then selectĀ LimitĀ and add at least oneĀ AR Code.
- Click Accept.Ā
- Then selectĀ Full.
- Now clickĀ Back.Ā
- AndĀ Back again.
- If it is set toĀ Limit, then selectĀ Full.Ā
- ClickĀ Accept.Ā
- If a limit is desired, then selectĀ Limit again and add the desiredĀ AR Code(s).
- ClickĀ Accept.
- Now clickĀ Back.Ā
- AndĀ Back again.
- If it is set toĀ Full then, then selectĀ LimitĀ and add at least oneĀ AR Code.
- Verify that all required Attributes are populated by selecting theĀ Attributes tab.
- If any Attributes are highlighted in red, that means they are required and missing a valid entry. To set an Attribute, clickĀ Update underneath the Attributes tab.
- Select the desiredĀ Value for the required attribute.
- ClickĀ Accept.
The above should resolve the causes listed in the Cause panel, but if they do not resolve the issue, then other settings will need to be evaluated as potentially causing this issue.
Additional Information
Additional resources for working in CSS can be found here:Ā Master Article - CSS