SSRS Report Connection failing - 400 Bad Request

Description of Issue

The Reports Connection in Time and Attendance is failing and reports are not able to run

The test connections returns the following error:

400 Bad Request - The base URL of the SSRS report server setting may not be formed correctly (make sure there is a "?" after ReportServer in the URL)

Context
  • Time and Attendance

  • T&A

  • ExecuTime

  • SSRS Reports Connection

Cause

The Base URL of the SSRS Report Server isn't formatted correctly

Resolution

Note: The correct format for the SSRS URL within the Application is: http(s)://reportservername/ReportServer?/Executime%Reporting/Reports/dbname

To obtain the http(s), reportservername, and dbname, the quickest solution is via Tyler Deploy. 

  1. Navigate to the Tyler Deploy home page at https://tylerdeploy.com/

  2. Sign into Tyler Deploy

    1. If Tyler Deploy access is needed, user must register for access - How to register for access to Tyler Deploy

  3. Select the Product Configurations drop down at the bottom of the left-hand side bar and choose ExecuTime

  4. Select the desired environment from the drop down

  5. Scroll to the Database Info section and note the Database Name

  6. Scroll to the SSRS: ExecuTime 2020.3 and above only section and make note of the SSRS Report Server URL

    1. example: http://reportservername/ReportServer

  7. In the Base URL of the SSRS report server field, enter:

    1. http(s)://reportservername/ReportServer?/Executime%Reporting/Reports/dbname

      1. http(s)://reportservername/ReportServer being obtained from Step 6

      2. dbname being the Database Name obtained from Step 5

  8. Click Save for the new changes to apply. 

  9. Select Test Connection to confirm the connection is now successful

Additional Information