Invalid Credentials After Cloud Admin Password Reset

Description of Issue

Reset password through Cloud Admin but it provides an invalid credentials error upon login

Context
  • Munis
  • Cloud Admin
  • Google Chrome
Cause

Web browser is caching old password and not prompting to update with the new password

Resolution
  1. Reset password following the steps provided here How to: Reset Munis Password
  2. Log into Cloud Admin https://muniscloud.tylertech.com
  3. Delete the autofill password from the web browser
  4. Type in new password that you just set in Step 1
  5. Accept when web browser prompts to replace old password with new one
Additional Information

Contact Tyler Systems Management Support for further assistance.