Unable to Approve time card when assigned to criteria

Description of Issue

Client reported that a timekeeper was unable to approve employees even though their criteria was assigned to the employee and the employees shows up in time approvals/time summary. The approve and Approve & Submit button were not visibly there.

Context
  • ExecuTime

  • Time & Attendance

  • Time Approvals

  • Workflow

  • Approvals

Cause

The cause was due to the role not being configured correctly, Current, Previous and historical period approval was not selected.

Resolution
  1. Login to Time & Attendance with Admin Access

  2. Click System Admin

  3. Click Security & Permissions

  4. Click the Edit Pencil Icon for the role in question assigned to the employee

  5. Scroll down to Supervisor Actions > Time Approvals

  6. Check Mark the follow Current Period Approve, Current Period Reject, Previous Period Approve, Previous Period Reject, History Period Approve, History Period Reject You may also want if you have access to mobile enable Mobile Approve and Reject also.

  7. Click Save

  8. Verify the approver can now see the approve buttons.

Additional Information