Update OIDC Client Secret Only in Admin Center



Description of Issue

Azure/Entra or Google Client secret needs to be updated for any reason.



Context
  • Authorization code

  • Invalid social token

  • Admin Center

  • Tyler Identity Workforce 

  • TID-W

  • Azure

  • Entra

  • Google ID

  • Preventative maintenance



Cause

Client secret needs to be updated for any reason



Resolution
  1. Gather the new secret and expiration date from your federation (Entra/Azure, Google, ADFS)

  2. Access Admin Center from https://<CustomerIdentifier>-admin.tylerportico.com/org/admin-center/dashboard

    1. Ex: https://tylertowntx-admin.tylerportico.com/org/admin-center/dashboard

  3. Within the left panel, navigate to Identity workforce > Identity providers

  4. Click the right arrow (>) to the right of the name (under Status column) that you are looking to make the change for

    1. Click Edit

  5. Update client secret with new secret value

  6. Update Secret expiration with secret expiration date

  7. Click Next

  8. Optional: Click Test identity provider configuration which will bring you to your sign in page

  9. Click Next

  10. Click Close



Additional Information











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