Invoice Paid in Cashiering not Reflected in TPAR



Description of Issue
  • Invoice was paid in full, but TPAR still reflects an amount due.

  • Receipt in Cashiering and External System indicates amount was paid, but this was not communicated back to TPAR due to an error.



Context
  • TPAR

  • Parks & Rec

  • Tyler Parks and Recreation

  • Cashiering



Cause

This can happen for various reasons. If clients are running version 2022.1.7 or lower, this is due to a bug that is addressed in version 2022.1.8. If this is the case, you can reconcile affected transactions using the steps below.



Resolution

These steps should only be performed with 100% confidence that the amount was indeed paid in full, and is reflected correctly in Cashiering or through the External System. Contact Tyler Parks & Rec Support for any clarifications or additional assistance.

  1. Navigate to Administration>System Settings>Integration Settings.

  2. Click to Expand the Cashiering Integration Settings.

  3. Screenshot the information displayed. Then toggle it Off and Save.

  4. Navigate to Parks & Rec > Contacts > Search.

  5. Search for the affected contact and click the Arrow to pull up their page.

  6. Click on Invoices.

  7. Click the Arrow on the invoice you'd like to pay. Instead of redirecting to Cashiering, it will have you choose a Payment Method within TPAR. Enter the same info as the original transaction, as close as possible.

    1. For Credit Card Transactions, ensure a processor is not linked in Payment Method settings. This will redirect to the processor portal and charge the client again. A Credit Card Corrections Payment Method, set to the Other system tender type, can be used in these instances.

  8. Verify the invoice is paid by going back to the Contact record and ensuring their balance due has changed.

  9. Navigate back to Administration>System Settings>Integration Settings and turn Cashiering back On. The configuration should be retained, but use the screenshot taken earlier if needed.

  10. Save. 



Additional Information

These steps should be performed after business hours. Any new transactions taken while Cashiering is disabled will only be processed and reflected in Parks and Rec.