TPAR Unable to Create Invoices
Description of Issue
Using the Pay Later or Pay Now option in Parks & Rec results in the error: Failed to successfully create invoice. Please contact technical support.
Error logs show the following: System.NullReferenceException: Object reference not set to an instance of an object. at Tyler.ParksRecreation.Data.Core.AzureDateTimeHelper.ConvertTimeForStorage(DateTime initialTime, TimeZoneInfo timeZoneInfo)
Context
- Parks & Recreation
- TPAR
- Tyler Parks and Rec
- MSDTC
- Unable to process transactions
- Unable to create invoices
Cause
MSDTC settings are configured incorrectly and not communicating transactional data to the server.
Resolution
- Check MSDTC setup on both the Munis database server and the server where TPAR Administration is installed (typically IS server). The settings need to match between each server.
- Open Component Services
- Double click Computers > My Computer > Distributed Transaction Coordinator
- Right click Local DTC and click Properties
- Click the Security tab
- Check Network DTC Access to enable
- Check Allow Remote Clients
- Check Allow Inbound and Allow Outbound
- Authentication setting should match between servers
- If changes were made, click Apply
- Click Yes to restarting services
- Click OK
- Repeat on second server
- Once DTC settings match, recycle TPAR application pools in IIS
- If the issue persists:
- Verify services for MSDTC are running
- Check if firewall is permitting the traffic
- Test MSDTC Connectivity Between Servers
Additional Information
For further assistance, please contact Tyler Systems Management Support or log a case via the Online Support Client Portal.