TCM Full Client install JLink not working NoSuchFileException error





Description of Issue

When installing the JLink full client an error window appears stating NoSuchFileorException during installation



Context
  • TCM JLink 2019.+



Cause

The user's desktop folder is being redirected to a network location and the program shortcut cannot be created



Resolution
  1. Create a Desktop folder in the user's directory.

    1. Open File Explorer

    2. Go to C:\users\%UserName%

    3. Create a folder named Desktop

  2. Run Jlink installer (Launcherstageone.exe) from the Downloads folder

  3. Copy shortcut from C:\users\%UserName%\Desktop to the users desktop



Additional Information

The installer is hard coded to use the local desktop directory which does not exist when the users desktop is redirected to a network folder.