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Crystal Report in BOE does not work.

Crystal Report in BOE does not work.





Description of Issue

Crystal reports works standalone, but does not work after uploading to Business Objects.



Context
  • Crystal Reports

  • Business Objects Enterprise, BOE

  • ODBC connection

  • Self-hosted, OnPrem Clients.

  • Tyler Hosted, SaaS Clients.



Cause

Crystal report stores the ODBC connection name used when building the report and searches for this ODBC connection on the BOE server. When a ODBC connection with that name is not present on BOE Server, the report fails to run on BOE.



Resolution

Step-1: Check the ODBC connection name on BOE Server

  1. Run the odbc32.exe application found in C:\Windows\SysWOW64

  2. Note the name of ODBC connection that is used by BOE.

Step-2: Check the ODBC connection name stored in the Crystal Report file:

  1. Open the report file (ends in .rpt) in Crystal Reports application.

  2. From the top menu, click on Database and select Set Datasoruce Location.

  3. In the top panel Current Data Source, note the name of the datasource under report.

The two names should be the same(including case). If the one in report file doesn't match the one on BOE server, the report file will need to be re-pointed to a connection that has the same name.

Re-pointing the Crystal report file to a new connection name

  1. Create an ODBC connection and name it the same as one in BOE Server.

    1. Create ODBC connection for SaaS clients if you are SaaS hosted.

    2. Create ODBC connection for OnPrem clients if you are hosted OnPrem.

  2. Delete the ODBC connection with old name and run the report.

  3. The report will ask to choose an ODBC connection, choose the new ODBC you just created.

Save the report and publish it to Business Objects Enterprise.



Additional Information