Account Restrictions Exist Error

Description of Issue

Receiving Account Restrictions Exist error when attempting to release or post a transaction in Munis

Context
  • General Ledger
  • Accounts Payable
  • Inventory Management
  • Purchasing 
  • General Billing Adjust Invoices (gbinvmnt)
Cause
  • User did not have permissions to the GL account and Applicable Program
  • Site keyed in several different segment types on the range section instead of adding separate access for each type of account segment
    • If the GL Segments do not exist together as an account string in Munis, the segments should be on separate records
  • Site only added a From Segment and not a To Segment
  • Use Tax Object Codes not included
Resolution
  1. Navigate to the User Attributes program either by searching or via the following path: System Administration > Security > User Attributes
  2. Click Search.
  3. Enter the User ID, Name, or E-mail address for the affected user.
  4. Click Accept. 
  5. View the Roles tab and determine which role(s) grant the GL Account Access and which should be updated.
  6. Navigate to the Roles program either by searching or via the following path: System Administration > Security > Roles 
  7. Click Search.
  8. Enter the Role determined in step 5.
  9. Click Accept.
  10. Click the General Ledger folder.
  11. Click into Account/Segment group access folder in the Data Access section. 
  12. Any one segment of the full account that is being accessed must exist here. 
    1. If a segment does not exist, click Add. 
    2. Choose the Type. 
    3. Enter the From and To range. 
    4. Click Accept. 
  13. If Account Access is more strictly limited, then make sure that the ranges do not exclude any piece of the account that is being accessed. For example, if the role grants access to the Org, make sure it does not exclude the Fund, Object, or Project.
  14. Check the Applicable programs hyperlink and make sure that the program is listed here. 
    1. If the program is not listed, click Update under the Applicable programs. 
    2. Click Select Programs. 
    3. Check the desired programs or choose Clear All or Select All. 
    4. When the selections are correct, click OK. 
    5. Click Accept. 
Additional Information