Exception when clicking Job Description in ESS

Description of Issue
  • An error is given when employees click a Job Description link in ESS
  • When we go to Employment Opportunities on ESS and click on the job description, we receive an error stating We encountered a problem and We are currently experiencing difficulties processing this transaction. how do we resolve?
  • Exception Error shows as Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index
Context
  • Munis
  • Human Capital Management (HCM)
  • Employee Self Service (ESS)
  • Tyler Content Manager (TCM)
  • Recruiting
  • Employment Opportunities
Cause
  • The Job Description Attachment in TCM is not marked as Public
Resolution
  1. Navigate to the program Job Class Master or Position Control depending on where the Job Description setup is performed
    1. Menu > Human Capital Management > Human Resources > Position Control and Budgeting > Position Control
    2. Menu > Human Capital Management > Payroll > Payroll Setup > Job Class Master
  2. Click Descriptions from the menu
  3. Select Search and locate your issue description record
  4. Click Attach from the menu and launch TCM
  5. Review for the option Public Flag located under the Attachment details
  6. Set this flag to the option YES
  7. Click the Save icon to lock in your changes
  8. The description hyperlink should allow for the file to be downloaded to the browser
Additional Information
  • Please reach out to Munis Human Resources Support with any additional questions