Exception when clicking Job Description in ESS
Description of Issue
- An error is given when employees click a Job Description link in ESS
- When we go to Employment Opportunities on ESS and click on the job description, we receive an error stating We encountered a problem and We are currently experiencing difficulties processing this transaction. how do we resolve?
- Exception Error shows as Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index
Context
- Munis
- Human Capital Management (HCM)
- Employee Self Service (ESS)
- Tyler Content Manager (TCM)
- Recruiting
- Employment Opportunities
Cause
- The Job Description Attachment in TCM is not marked as Public
Resolution
- Navigate to the program Job Class Master or Position Control depending on where the Job Description setup is performed
- Menu > Human Capital Management > Human Resources > Position Control and Budgeting > Position Control
- Menu > Human Capital Management > Payroll > Payroll Setup > Job Class Master
- Click Descriptions from the menu
- Select Search and locate your issue description record
- Click Attach from the menu and launch TCM
- Review for the option Public Flag located under the Attachment details
- Set this flag to the option YES
- Click the Save icon to lock in your changes
- The description hyperlink should allow for the file to be downloaded to the browser
Additional Information
- Please reach out to Munis Human Resources Support with any additional questions