Enterprise Forms processing slow

Enterprise Forms processing slow

Description of Issue
  • Archiving is taking all day
  • Emails are taking hours to process
  • Downloading and archiving RE bills are slow
  • Forms are printing slow
Context
  • EERP
  • Enterprise Forms
  • Archive
  • Email
  • Print
  • OnPrem
  • SaaS
Cause
  • Large amount of files being processed
  • Number and order of Steps in the ReadyForms Delivery Definition
  • Anti-malware and anti-virus are scanning the files
  • Enterprise Forms Administration debugging toggle is ON
Resolution

The form/data will process based on the order the steps were created. So, they will process one after another and not simultaneously. If the amount of files being processed are high, most likely it will take some time to process.

To avoid longer processing time than normal, please review the following:

  1. Update Enterprise Forms to the latest version: 
  2. Verify if anti-virus and anti-malware has proper exceptions/exclusions:
  3. Verify if debugging in Enterprise Forms Administration is ON and turn it OFF
  4. Make sure all Assets (images and .rtf files) added to Template were properly created based on recommendation below
    1. How to create a Logo to add on the Template
    2. Signature change for standard Enterprise Forms Template
    3. Update Client Address information printing on Enterprise Forms Template
    4. Backer on Enterprise Forms Template is Right Justified
    5. If Custom Template, please create a case with Forms support team
      1. How to identify if Template is standard or custom
      2. Difference between Standard and Custom Enterprise Forms
  5. Set Execution Options, all of the Steps within a ReadyForms Delivery Definition, to process immediately: EERP Enterprise Forms processing progress bar window takes hours to finish

If Printing is slow, in addition to all of the steps above, please also verify the following:

Additional Information






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