EPL Receipts Duplicated in Enterprise ERP Payment Entry

EPL Receipts Duplicated in Enterprise ERP Payment Entry

Description of Issue

Error releasing batch number XXXXX. (System Log)

Payment already exists with External Batch Id'XXXXXXXX ' and External Payment Id 'REC-XXXXXX-XXXX' (System Log)

Context
  • Enterprise Permitting & Licensing 
  • Payment Entry
  • System Log
  • arwshdlr (webservice)
  • arwsmspt (webservice)
Cause

A batch of 120 transactions or more was exported from EPL. The arwsmspt webservice times out after 60 seconds (industry standard), after which point EPL attempts to resend. This can sometimes result in duplication of receipts in Enterprise ERP Payment Entry. 

Resolution

As a workaround, limit the number of transactions in an EPL export to under 120. 

For any receipts that are duplicated in EERP, follow steps to reverse posted payments: Reversing Posted Payments or to reverse unposted payments: Reversing Unposted Payments.

Additional Information






Related content