Published May 16

Asset Registry produces error when saving Asset

Description of Issue
  • Asset Registry produces an error when user attempts to save a newly added Asset 

  • An error occurred when trying to add an asset. Please see System Logs for more information

  • System log error:
    An exception occurred in AddAsset
    Inner Exception Message: System.Transactions.TransactionManagerCommunicationException: Communication with the underlying transaction manager has failed. ---> System.Runtime.InteropServices.COMException: The MSDTC transaction manager was unable to pull the transaction from the source transaction manager due to communication problems. Possible causes are: a firewall is present and it doesn't have an exception for the MSDTC process, the two machines cannot find each other by their NetBIOS names, or the support for network transactions is not enabled for one of the two transaction managers.

Context
  • Enterprise Asset Management 

  • EAM

Cause

Error occurs due to firewall settings 

Resolution

Contact Tyler System Management OnPrem/SaaS Support to test the MSDTC connectivity between the app server(s) and database server(s) to determine if the issue is due to a firewall setting or server configuration 

Workaround: Use Assets 









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