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Description of Issue

I see information in our OKTA admin panel stating that our AD agent needs to be upgraded. Can you provide instructions or assistance with this?

Context
  • Tyler Identity
  • Okta
  • Okta AD Agent
Cause

Okta AD Agent out of date or not synced with another agent

Resolution

Important: During update, Agent connections are temporarily down, so if you only have one operational agent available, users won’t be able to sign in during the update

Updating from version 3.12.0 and later

  1. Login to your Admin Center as an Org Admin e.g. https://<customeridentifier>-admin.tylerportico.com/org/admin-center
  2. Navigate to Identity Workforce>AD Agents
  3. Click on the Okta login
  4. Login with your oktaadmin@tidsupport.com username and password. Note that Tyler does not retain these credentials
  5. Navigate to Settings>Download and download the latest available AD Agent
  6. Copy the installer to the server with the existing AD Agent install

Special considerations for installation/update of version 3.18 and later:

AD Agent now uses a very secure authentication method, but it comes at the cost of ensuring that AD Agent member servers are time-synched with a standard NTP (Network Time Protocol) server pool

The maximum allowed clock skew is 30 seconds. Larger time disparities may cause connection issues

Please consult this Okta article for further details: https://support.okta.com/help/s/article/ad-agent-connection-issues-for-version-3-18-0-and-above?language=en_US

  1. Run the installation and follow the prompts, accepting all defaults
  2. Once the install is complete, return to Admin Center under the Identity Workforce>AD Agents and ensure that the status reflects OPERATIONAL and on the latest GA version
  3. If you have multiple agents installed, repeat steps 6-8 to update the agent to the same GA version

Updating from version 3.11.0 or older

  1. Copy the installer to the server with the existing AD Agent install
  2. Uninstall the current installer from Windows Programs and Features
  3. Rename the Agent folder, located under C:\Program Files (x86)\Okta, to a name of your choosing
  4. Run the installer and follow the steps from this article: https://support.okta.com/help/s/article/okta-ad-agent-registration-using-oauth-2-0?language=en_US
    1. If prompted to sign in to Okta, use the username: oktaadmin@tidsupport.com and the password that was setup for this account in Admin Center
      1. For instructions on how to reset the Okta admin password - Reset Okta AD Agent password from Admin Center
  5. Once the install is complete, return to Admin Center under the Identity Workforce>AD Agents and ensure that the status reflects OPERATIONAL and on the latest GA version
  6. If you have multiple agents installed, repeat steps 6-8 to update the agent to the same GA version 





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