Description of Issue
Azure/Entra or Google Client secret needs to be updated for any reason.
Context
- Authorization code
- Invalid social token
- Admin Center
- Tyler Identity Workforce
- TID-W
- Azure
- Entra
- Google ID
- Preventative maintenance
Cause
Client secret needs to be updated for any reason
Resolution
- Access Admin Center from https://<CustomerIdentifier>-admin.tylerportico.com/org/admin-center/dashboard
- Gather only the new secret from your federation (Entra/Azure, Google, ADFS)
- Navigate to Identity workforce > Identity providers
- Click the kebob (three dots) to the right of the Domain that you are looking to make the change and click Edit
- Update only the client secret and click save
- Although optional, we strongly encourage adding the expiration date of your new Secret to the admin center
Additional Information
- Help pages on generating secrets:
- Only update the Secret Value. Although on the backend of Azure and Goole API manager both ID and Secret are re-generated as a pair, do not update the original Client ID.
- How to gain Org Admin access to Admin Center
- If you need assistance getting access to the Admin Center, please contact TSM support
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