Description of Issue
When viewing a role's data access tab via the Roles program in Munis the MU_ security group it is linked to shows as *UNKNOWN*. This may also be causing a Server Connection Warning HTTP 401() error as well when users attempt to access TCM through Munis.
Context
- Munis
- Enterprise ERP
- Tyler Content Manager
- CM
- TCM
- TCM Permissions
Cause
The MU_ Group may be listed as *UNKNOWN* due to:
- it not yet existing in that corresponding TCM environment
- it is a custom group created within the CM full client with an ID that is more than 20 characters long
- the master password needs to be reset in the TylerCM for Munis Settings screen to refresh the connection between Munis and TCM
Resolution
- Verify the MU_group exists in the corresponding TCM environment:
- In that same Munis environment, navigate to Tyler Menu > System Administration > General Administration > TylerCM for Munis Settings
- Launch the first URL in a new tab
- Launch the TCM Full Client via Webstart (uses Java) or J-link (does not use Java)
- Login to the TCM Full Client with administrative rights
- Administration > Security Manager > Groups > Verify if the MU_Group exists
- If the MU_ group exist ensure its Group ID is more than 20 characters
While TCM will allow more characters when creating a custom group, Munis limits the amount of characters to the Group ID to 20 - If the MU_Group exists, navigate back to Munis to complete a master password reset:
- Tyler Menu > System Administration > General Administration > TylerCM for Munis Settings
- Select Master Password using the tcmadmin credentials found on site report
- Select Rebuild TCM Caches
- Navigate back to Roles to see if the MU_Group populates without error. If not, please contact TCM Support at +1 (800) 772-2260 ext 3807
- If the MU_Group does not exist in the corresponding TCM Full Client:
- Check to see if the group was created in one of the other CM environments and recreate it within the missing environment if that is the case
- If the group does not exist in any environment please contact TCM Support at +1 (800) 772-2260 ext 3807
Additional Information
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