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Description of Issue
  • When attempting to cancel a rental/class/membership and apply an account credit, receive an error message: an error has occurred and has been logged.
  • When integrating Parks & Rec with Cashiering, Account Credit does not appear as an available Tender Type.
Context
  • TPAR
  • Tyler Parks & Recreation
  • Tyler Parks & Rec
  • Cashiering
  • Tyler Cashiering
Cause

Account Credits are not configured, either in TPAR or Cashiering (depending on whether they are integrating).

Resolution

Setup in TPAR

  1. Navigate to Administration>Cashier Setup>Payment Methods.
  2. Create a Payment Method by selecting Create.
  3. Set the Tender Type to Account Credit.
    1. Check Is Active.
    2. Check Is Refund Type.
    3. Check Use Fee Liability GL Account for Refunds.
  4. Save.
  5. Navigate to Administration>Cashier Setup>Fee
  6. Go to the GL Accounts tab.
  7. For any fee you would like to set the option of depositing or withdrawing an account credit, Add Account Credit GL Accounts.
    1. Choose a Liability account as the Debit account. (Note: the specific name of this account is subject to variation depending on what was set up during site implementation).
    2. Choose the same Credit account as you would for other Payment Methods.
  8. Repeat this process for any Fee that may apply a refund as an account credit.

Applying in TPAR

  1. Using class as an example, navigate to Class Details on any class.
  2. Click the Delete button (trashcan icon) to begin the refund process.
  3. Choose Account Credit as the refund option.
    1. If a Contact has an account credit, pulling up that name in Contact Search will show the credited amount. There is an option to refund through this menu, in cases of transferring the amount to Cash, Credit Card reimbursement, etc.
  4. In any future transactions for this Contact, Account Credit will now be an available Payment Method in the checkout process.

Integrating With Cashiering

  1. This guide assumes that Cashiering is already activated under Integration Settings in TPAR, and that Parks and Recreation is listed as an External System in Cashiering.
  2. Navigate to Administration>Tender Types.
  3. Click Edit (pencil icon) on the Account Tender Type.
    1. If there is no Account Tender Type Listed, select the + button instead. Choose Account from the Type drop-down menu.
  4. What is listed under the System Tender Type from TPAR Payment Methods must be entered in the External Reference field for the corresponding Cashiering Tender Type. In this case, enter Account Credit in the External Reference field for the Account Tender Type.
  5. Save.

Applying in Cashiering

  1. Follow steps for Applying in TPAR. The Pay Now button for the new transaction will redirect to Cashiering. Ensure a Contact with an account credit is added as the Payer.
  2. Select Account as the Tender Type.
  3. Click Complete and Done.
  4. System will redirect back to TPAR to generate a receipt.
Additional Information

TPAR Only

  • A standalone Add-On Fee cannot be refunded to account credits. However, the account credit option should still be set under the GL Accounts tab for the Add-On Fee, as these items can sometimes be associated with classes, memberships, or rentals being refunded for credit.
  • If the credit does not cover the entire cost of the new transaction, the payment page automatically indicates a split payment. If the Contact is using the citizen portal, the other split payment will automatically specify a credit card as the payment method for the remaining balance. The registrant cannot change this and must complete the credit card options to complete the payment.

  • If there are multiple items/fees in your Cart, all of them must have Account Credit listed as an available Payment Method. The system will only show Payment Methods that the fees all have in common.

Cashiering

  • The External Reference field may be necessary for other Tender Types in the event of a split payment. If the Credit Card Payment Method in TPAR uses Other as the System Tender Type, that will need to be input into the External Reference field in Cashiering.
  • The Payment Type in Cashiering should default to the Parks & Recreation Invoice Payment Type set up during TPAR Implementation.
  • Whatever the batch default Tender Type is set up to be in Cashiering is what will pull up, regardless of what you choose as the Payment Method in TPAR. For example, if you choose Account Credit as the Payment Method in TPAR and then click Pay Now, it will direct you to Cashiering where the batch default (usually Cash) will be selected first. You will have to again select Account to apply the credit. One does not need to select a Payment Method before going over to Cashiering, unless they are applying a Cart Fee.

Tyler Parks and Rec Account Credit Transfer Issue - undefined





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