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Description of Issue

Emails aren't sending from ExecuTime, including test emails when using Office365 as the SMTP Server

Context
  • ET
  • ExecuTime
  • SMTP
  • Emails
  • v2020+
Cause

A java mail property that enables TLS when authenticating with Office365 is missing in the Java Mail Properties field

Resolution
  1. The Java Mail Properties field can be found by navigating to System Admin > UI Environment Flags > Communication
  2. On this page, look for the Java Mail Properties field
  3. Add the following java properties to the end of the values in the field: mail.smtp.starttls.enable=true
    1. for example: mail.smtp.auth=true;mail.debug=false;mail.smtp.timeout=300000;mail.smtp.starttls.enable=true
  4. Select Save
  5. Test sending emails to verify that you are no longer receiving the error message and that you receive Email Sent Successfully
    1. If you receive the same error, verify that you entered the correct java mail properties in the field.
    2. If you receive a new error, please create a case with the ExecuTime TSM Team
Additional Information

Office365, if using port 587, requires TLS for authentication. Entering the java mail property tag for enabling TLS will resolve the issue. 

For versions v2019 and prior, refer to 451 5.7.3 STARTTLS is required to send mail version 2019 and prior





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