Description of Issue
HTTP 500 internal server error accessing Munis Dashboard after updating SSL certificate in IIS
Certificate was updated and now all users are unable to view dashboard and are receiving an HTTP 500 internal server
Context
- Munis 11.3
- Internet Information Services (IIS)
- SSL certificate
- GAS connection to Munis .NET
- Tyler Dashboard
Cause
SSL certificate was incorrectly bound in IIS
Resolution
- Open IIS on the server where Dashboard is hosted (often located on the Munis Application server)
- In the Connections panel, expand the server name and Sites folder by clicking the arrows
- Right click Default Web Site > Edit Bindings
- OR, click Default Web Site, then in the Actions panel, click Bindings…
- Double click the binding with Type: https
- OR, select the binding with type https and click Edit
- From the SSL Certificate dropdown, select the new certificate
- You can click View to review certificate details to verify the correct certificate is selected
- If the new certificate isn't available in the drop down, you will need to import it into IIS
- If not filled in, add the Host Name to the open field above the SSL certificate section
- Click OK, then click Close
- Repeat steps for each web site under Sites
- Open the Dashboard web page in a browser
- Click the security icon in the browser and view the certificate to ensure correct certificate is applied
- If the correct certificate doesn't show up, open an administrative command prompt and enter iisreset
- Please note: This will reset all IIS services and cause an interruption in connectivity for end users. Ensure they are aware this is happening.
- Test the website again to ensure it is now showing the updated certificate
Additional Information
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