Description of Issue
Following a password change all Tyler Cashiering Reports are failing with the error: Exception (System Exception): The HTTP request is unauthorized with client authentication scheme 'Ntlm'. The authentication header received from the server was 'NTLM'. Inner Exception (System Exception): The remote server returned an error: (401) Unathorized.
Context
- Tyler Cashiering
- Password Reset
- Password Update
- Reports
- On-Prem
- tylerservice
- Service Account
Cause
Tyler Cashiering versions 2018.1 and above use service account credentials (such as tylerservice) stored in an encrypted AppSettings.config file to make a connection to SSRS for reports.
Resolution
Versions not deployed through Tyler Deploy
- Needs to be corrected manually
- Please contact Tyler Systems Management Support or log a case via the Online Support Client Portal
Versions deployed through Tyler Deploy
- Option 1: Manual workaround. Requires restarting Cashiering application pools, making Cashiering unavailable momentarily
- Please contact Tyler Systems Management Support or log a case via the Online Support Client Portal
- Option 2: Update password in Tyler Deploy variables and redeploy. Cashiering will be unavailable for the length of the redeployment
- Changes can be made in Tyler Deploy by an administrator with Deploy\Configure permissions
- - OR - Contact Tyler Systems Management Support or log a case via the Online Support Client Portal
Update password in Tyler Deploy variables
- Log into Tyler Deploy and select the applicable client tenant
- Navigate to Product Configurations > Tyler Cashiering Server
- Select the applicable environment from the drop down
- Expand Tyler Cashiering Server
- Scroll down to SSRS
- Update the password for SSRS Server Account Password
- Scroll back up and click Save
- Click Go to Deployment
- Force redeploy Cashiering on the same version
- Please note: Cashiering will be unavailable for use during the redeployment
- Repeat for all Cashiering environments
Additional Information
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