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Description of Issue

Workflow services are not currently available.

Error message can be located at the top-middle of the screen in red letters.

Context
  • ExecuTime 
  • ET
  • Tyler Workflow
  • Versions: 2019 / 2020 +
Cause

TWF Services are not starting correctly.

This can occur due to:

  • Server was rebooted during update
  • Tyler Connection Services have been changed
  • Restarting ET Application Services
Resolution
  1. Once logged onto the ExecuTime Server, pull up Task Manager (right click on the Task Bar) > Services Tab > Open Services.
  2. Locate TWF Service. Will look like the one of the following:
    • TWF Command Runner
    • TWF Diagnostic 
    • TWF Director
  3. Click Stop this Service to the left in the following order:
    • TWF Director 
    • TWF Command Runner
    • TWF Diagnostic
      • Service Control box will pop up with a progress bar. This will close on its own once the services is finished stopping.
  4. Click Start the service to the left in the following order:
    • TWF Director
    • TWF Command Runner
    • TWF Diagnostic
      • This typically takes a few minutes to fully start back up.
  5. After allowing the system a few minutes to start back up, verify the services are back online by navigating back to the ExecuTime Application.
  6. Login to the Application
  7. Navigate to System Admin > Workflow Management > Workflow Connectivity 
  8. Click the Test Tyler Workflow Connectivity
  9. Notice that the error is now not displaying at the top of the screen.


Additional Information

If you still see the Workflow services are not currently available, You can run the Check External Service Status Job to attempt connection to the TWF Services.

  1. System Admin
  2. Scheduled System Jobs
  3. Click the square & arrow icon next to Check External Service Status Job to manually run the import.





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