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Description of Issue

Emails aren't sending from ExecuTime, including test emails when using Office365 as the SMTP Server

Context
  • ET
  • ExecuTime
  • SMTP
  • Emails
  • v2018+
Cause

A java mail property that enables TLS when authenticating with Office365 is missing in the Java Mail Properties field

Resolution
  1. The Java Mail Properties field can be found in two separate locations depending on the version of ExecuTime
    • If ExecuTime is on the v2018 branch, you'll want to navigate to System Admin > UI Environment Flags > Admin
    • If ExecuTime is on the v2019.x branch or higher, then you'll want to navigate to System Admin > UI Environment Flags > Communication
  2. On these pages, look for the Java Mail Properties field
  3. Add the following java properties to the end of the value in the field: mail.smtp.starttls.enable=true
  4. Select Save
  5. Test sending emails to verify that you are no longer receiving the error message and that you receive Email Sent Successfully
    1. If you receive the same error, verify that you entered the correct java mail properties in the field.
    2. If you receive a new error, please create a case with the ExecuTime TSM Team
Additional Information

Office365, if using port 587, requires TLS for authentication. Entering the java mail property tag for enabling TLS will resolve the issue. 





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