Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Next »

Description of Issue

Old Receipt Attachments missing.

Can't see legacy receipts in new version.

TCM receipts attachments from old version are unavailable.

Misc Receipt Mapping Deleted.

Context
  • Payment Processing
  • Receipt Attachments
  • v2019.1+
Cause

In the new version, mapping keys are stored with different information on Category 02 receipts. In the new version, TCM uses a receipt's Bill Number to xconfuigure mapping, but legacy Misc Cash receipts do not have a bill number. Users will find they can not see attachments in the Receipts  program. 

Resolution

In order to restore mappings a utility must be run to set Bill Number equal to Receipt Number.


  1. Navigate to System Administration > General Administration > Diagnostic Utility and Runtime Information
  2. Click the Run Trace tab
  3. In the Program Id field type spattfix
  4. In Arguments type -FixARReceipt
  5. Set MU_DEBUG field to 99
  6. Click Run Trace

Utility make take several hours to run. Once completed, receipt attachments should be restored.

Additional Information

Please reach out to support for additional information. 





  • No labels