Description of Issue
When logging in you receive: 400 Bad Request Your request resulted in an error. Identity Provider OIDC Error Code invalid_social_token. Could not acquire access token from authorization code.
Azure or Google Client secret needs to be updated for any reason.
Context
- Admin Center
- Tyler Identity Workforce
- TID-W
- Azure
- Google ID
Cause
Client Secret has expired or needs to be changed for any reason
Resolution
Resolution 1
- Login to Ops Center as Org Admin from https://<CustomerIdentifier>-admin.tylerportico.com/org/admin-center/dashboard
- Ensure the contact is listed as an Org Admin
- Identity Workforce>Reestablish Federation
- Select desired Org Admin from drop-down
If the admin's email domain does not match the identity provider selected, you will be prompted to continue
- Click Create and send
- A message will show at the bottom Magic link sent successfully.
- Site contact will click on the link in their email, verify the federation information and update the Secret
Resolution 2
- Access Admin Center from https://<CustomerIdentifier>-admin.tylerportico.com/org/admin-center/dashboard
- Gather the new secret from your federation (Azure, Google, ADFS)
- Navigate to Identity workforce > Identity providers
- Click the three dots ⋮ to the right of the Domain that you are looking to make the change and click Edit
- Update the client secret and click save
- Although optional we strongly encourage adding the expiration date of your new Secret to the admin center.
Additional Information
Add Comment