Description of Issue
What can I remove on my server's drives to free up space?
Context
- Disk Space
- Server Maintenance
- Clearing Disk Space
Cause
Server drive is running out of disk space
Resolution
There are several targets when clearing disk space on a Munis server. You can run a disk space analyzer program such as TreeSize* to see the size of all folders including all subfolders and break it down to file level.
The following files/folders can be cleared:
- Data drive (we will use D: as an example drive letter):
- D:\TylerInstalls
- Used to store downloaded install files, can be removed once work is completed
- D:\TylerTempBackups
- Temporary backups from when work is being done
- Anything older than 30 days can be removed
- D:\fglgas*\gaslogs\*\isapidispatch
- GAS connections logs, only needed if we are currently troubleshooting GAS issues
- We recommend clearing anything older than 30 days
- D:\munxxx\logs\gas\*\log\isapidispatch - (app, svc, svcmss, and svcsched)
- Ex: D:\munprod\logs\gas\app\log\isapidispatch
- GAS connections logs, only needed if we are currently troubleshooting GAS issues
- We recommend clearing anything older than 30 days
- D:\munxxx\temp_xxx or D:\munxxx\temp
- We recommend clearing anything older than the last server reboot
- This also applies to all other Munis environments on the data drive (Ex: D:\muntest\temp_test or D:\muntest\temp)
- D:\Formunis\server*\backups
- Backups of forms jobs that have run. Keep last couple months for reference
- D:\TylerInstalls
- OS Drive (Usually C:):
- C:\inetpub\logs\LogFiles
- IIS logs, only needed if we are troubleshooting IIS issues
- We recommend clearing anything older than 30 days
- C:\Users\tylerservice\AppData\Local\Temp
- Temp staging files produced by Windows during processing
- We recommend clearing anything older than the last server reboot
- C:\inetpub\logs\LogFiles
Additional Information
- *TreeSize is an approved program that is often used to analyze disk usage. If not already installed, this can be downloaded to the server for free: TreeSize Free | JAM Software (jam-software.com)
- When clearing unneeded files, it is best to permanently delete them so they do not get sent to the Recycle Bin.
- Hold down the Shift key, then delete the item normally. You can press the Delete key, choose the Delete button from the ribbon, or right-click > then click Delete
- Are you sure you want to permanently delete these items? Click Yes
- Alternatively, from the File Explorer ribbon, click the Delete dropdown, then select Permanently Delete
- Hold down the Shift key, then delete the item normally. You can press the Delete key, choose the Delete button from the ribbon, or right-click > then click Delete
- If there are a large number of files (such as GAS logs), the files may need to be cleared in multiple groups so server resources do not freeze up.
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