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Description of Issue

We need to escalate a support case to increase visibility, how do we escalate a support case?

Context
  • Tylertech.com
  • Client Support
  • Online Support Incidents
Cause

User needs to escalate a support case

Resolution
  • If your situation or issue priority has changed, or if you feel you are not receiving the service you need, please contact the appropriate support product manager to escalate. The manager will follow up and determine the necessary action.
NameProduct ModuleEmailExtension
Brian GilmanMunis - Purchasingbrian.gilman@tylertech.com4436
Evan SmithMunis - General Ledger and Budgetevan.smith@tylertech.com 4621
Holly LaRouMunis - Equipmentholly.larou@tylertech.com4482
Tracy SilvaMunis - Payrolltracy.silva@tylertech.com4433
Ed HaggertyMunis - Human Resourcesed.haggerty@tylertech.com4464
Sonja JohnsonDirector of Software Support - Financials, Payroll, and Human Resourcessonja.johnson@tylertech.com4157
Peggy WintleMunis - Utility Billingpeggy.wintle@tylertech.com4567
Parker LaChanceTyler Cashiering, Tyler Payments, Tyler Parks and Recparker.lachance@tylertech.com4257
Frank KlingensmithMunis - Revenuefrank.klingensmith@tylertech.com4267
Steven JonesDirector of Software Support - Utility Billing and Revenuesteven.jones@tylertech.com4255
Patience StetsonMunis - State Reportingpatience.stetson@tylertech.com4165
Mark MorrillDevelopment Managermark.morrill@tylertech.com4198
Dean WilberDeployment Managerdean.wilber@tylertech.com4730
Brianna YoungTyler Systems Management - On-Premises Managerbrianna.young@tylertech.com4569
Zachary BartlettTyler Systems Management - SaaS Managerzachary.bartlett@tylertech.com4521
Ben KingDirector of Technical Servicesben.king@tylertech.com4867
Matt StoneSoftware Support Manager - ReadyForms, Reporting Services, TCMmatt.stone@tylertech.com4563
Adam ScheuchzerSenior Director of Technical Servicesadam.scheuchzer@tylertech.com4348


Additional Information
  • If you cannot reach the product manager or director, please call CJ McCarron, vice president of technical support, at 800-772-2260, Ext. 4124 (cj.mccarron@tylertech.com)
  • Please review our Technical Support Overview for Munis PDF for more information





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