Description of Issue
We need to escalate a support case to increase visibility, how do we escalate a support case?
Context
- Tylertech.com
- Client Support
- Online Support Incidents
Cause
User needs to escalate a support case
Resolution
- If your situation or issue priority has changed, or if you feel you are not receiving the service you need, please contact the appropriate support product manager to escalate. The manager will follow up and determine the necessary action.
Name | Product Module | Extension | |
---|---|---|---|
Brian Gilman | Munis - Purchasing | brian.gilman@tylertech.com | 4436 |
Evan Smith | Munis - General Ledger and Budget | evan.smith@tylertech.com | 4621 |
Holly LaRou | Munis - Equipment | holly.larou@tylertech.com | 4482 |
Tracy Silva | Munis - Payroll | tracy.silva@tylertech.com | 4433 |
Ed Haggerty | Munis - Human Resources | ed.haggerty@tylertech.com | 4464 |
Sonja Johnson | Director of Software Support - Financials, Payroll, and Human Resources | sonja.johnson@tylertech.com | 4157 |
Peggy Wintle | Munis - Utility Billing | peggy.wintle@tylertech.com | 4567 |
Parker LaChance | Tyler Cashiering, Tyler Payments, Tyler Parks and Rec | parker.lachance@tylertech.com | 4257 |
Frank Klingensmith | Munis - Revenue | frank.klingensmith@tylertech.com | 4267 |
Steven Jones | Director of Software Support - Utility Billing and Revenue | steven.jones@tylertech.com | 4255 |
Patience Stetson | Munis - State Reporting | patience.stetson@tylertech.com | 4165 |
Mark Morrill | Development Manager | mark.morrill@tylertech.com | 4198 |
Dean Wilber | Deployment Manager | dean.wilber@tylertech.com | 4730 |
Brianna Young | Tyler Systems Management - On-Premises Manager | brianna.young@tylertech.com | 4569 |
Zachary Bartlett | Tyler Systems Management - SaaS Manager | zachary.bartlett@tylertech.com | 4521 |
Ben King | Director of Technical Services | ben.king@tylertech.com | 4867 |
Matt Stone | Software Support Manager - ReadyForms, Reporting Services, TCM | matt.stone@tylertech.com | 4563 |
Adam Scheuchzer | Senior Director of Technical Services | adam.scheuchzer@tylertech.com | 4348 |
Additional Information
- If you cannot reach the product manager or director, please call CJ McCarron, vice president of technical support, at 800-772-2260, Ext. 4124 (cj.mccarron@tylertech.com)
- Please review our Technical Support Overview for Munis PDF for more information
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