PACE Program Plan Options

Description of Issue

What options are available for upgrade assistance?

Context
  • Enterprise ERP

  • Client Support

  • Upgrade Management Assistance

  • Training

  • Project Management

  • PACE

Cause

Tyler Technologies offers different types of upgrade assistance to meet your needs. 

Resolution

PACE Training Sessions

PACE Flex

  • With PACE Flex, clients may choose from two training formats, as needed: remote or on-site. On-site sessions must be scheduled in blocks of three or more days, and all travel fees are billed to the client as incurred. PACE Flex includes three (3) registrations to Connect, Tyler’s annual in-person user conference.

PACE Remote

  • PACE Remote provides an additional discount to those clients who plan to schedule all PACE sessions remotely. PACE Remote includes three (3) registrations to Connect, Tyler’s annual in-person user conference.

PACE Premium Plan

  • PACE Premium is designed to assist large and complex Enterprise ERP clients in ensuring long-term improvement and viability. PACE Premium combines discounted training, participation in the annual Tyler Connect conference, and annual investment assessments to help you maximize your Munis investment. PACE is part of Tyler’s commitment to EverGuide®, a continuous improvement initiative that includes training and consulting after implementation to ensure clients get the most from their investment.

Additional Information

Please review the Enterprise ERP PACE Training Flyer and the Munis PACE Premium Flyer for additional information.

Please review our PACE for Enterprise ERP (Munis) Overview and Upgrade Management Assistance document for additional support information.

Looking for more articles on PACE? Check out the Master Article - PACE for all related topics!