General Billing Invoice Import duplicate gbcusdat error



Description of Issue

GB Invoice Import error occurs on the GB Customer Data table.

  • Error inserting into General Billing Customer table. Status 268

  • Cannot duplicate key row in object dbo.gbcusdat with unique index gbcusdat1. The duplicate key value is



Context
  • General Billing

  • Invoice Import

  • Invoice Entry and Proof



Cause

Can occur when import contains multiple invoices with the same Customer number.



Resolution

Development is currently researching the issue, contact EERP Revenue Support for further assistance.

The error occurs a single time for every group of invoices sharing the same customer number. Once a Customer record is generated into the system, the import should no longer error for that specific Customer number. One workaround would be to remove duplicate customer numbers from the import before importing. Second workaround would be to get the error, then go into Invoice Entry and Proof and delete the invoices created by the partially generated Invoice Import batch, and reimport the file again. Repeat the process until all of the Customers have been generated into the system. The error message should indicate the Customer number that caused the duplicate key value.



Additional Information