How to Restart GAS for OnPrem Clients

Description of Issue

This article covers the process of restarting GAS (Genero Application Services) for OnPremise clients

Context
  • Munis

  • OnPremise Clients

  • GAS

  • GAS Restart

Cause

Client is having issues with Munis processes, and a GAS Restart is needed. 

Resolution

Please note: Restarting GAS typically should not be one of the first troubleshooting steps as it does not resolve the root cause. It can also clear out crucial information that would otherwise help lead to the root cause of the issue. Restarting GAS is an invasive process and will disrupt existing Munis connections for all users.

Method 1: Via Command Line

Note: The RestartGAS command script is located in the %Munis Drive%\cmd directory of the Munis application server. For this reason, this command can only be performed on the applicable environment's application server

  1. Log into the Application Server as Tylerservice or equivalent account

  2. Open Command Prompt (cmd.exe) as an administrator

  3. If you are looking to restart a specific app pool, type the command restartgascmd <desired application pool> (Ex: restartgascmd GasProd)

  4. If you are looking to restart all application pools for that environment, the structure will be restartgascmd *<desired environment>* (Ex: restartgascmd *prod*)

  5. Close the Command Prompt window once the process completes

Method 2: Via the MIU

  1. Open the Managed Internet Update (MIU) on the application server

  2. Select the applicable environment

  3. Select Utilities then select Restart Gas AppPools

  4. Select Yes to continue (There will be a brief screen stating Restarting GAS. Environment: XXXX)

  5. Once complete, you will return to the MIU environment page

Additional Information

Restarting GAS is an invasive process and will restart all applications pools on that server for the specified environment tag. If your site has load balanced application servers, GAS will need to be restarted on both application servers.

 Restarting GAS is not a permanent/root fix for an issue. If your site needs to consistently restart GAS because of certain errors or because of performance issues (high CPU/memory), please reach out to the Tyler System Management (TSM) team to review.

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