Paymentus Integrations and Payments Are Failing Post-Upgrade
Description of Issue
Post-upgrade, Paymentus is unable to initiate a successful integration (connection) to a Munis environment for payment processing.
Context
- Enterprise ERP
- Munis
- Munis Self Service
- MSS
- Tyler Cashiering
- Paymentus
- v2019.1+
- IVR
- Munis Upgrade
- SaaS
Cause
Paymentus needs to update the IVR or INT connection strings and ensure that the newer external IP addresses have been added to the allow list for a successful transfer of Tyler traffic.
Resolution
- Please reach out to the engineer that handled your scheduled engagement. The engineer will provide you with the updated IVR URLs that Paymentus requires to successfully update the payment integration.
- Create a support ticket with Paymentus (please select the Client Support tab), that indicates that an upgrade will / has been completed for <environments> on <dates that you were / are scheduled to be upgraded on>. You will then need to supply the following information when creating the case:
- The updated IVR URLs provided from SaaS Deployment.
- These are typically in the formatting of: https://<crm-identifier>ivr<-env>.tylerhost.net/<XXXX><env>/munis/gas/svc/ws/r/mugws/arwshdlr or https://<crm-identifier>int-<-env>.tylerhost.net/XXXX<env>/munis/gas/svc/ws/r/mugws/arwshdlr
- The updated external IP addresses to allow.
- For production environments, please ensure 208.64.237.132 (for use with IVR re-directs) and 208.64.237.166 (for use with INT re-directs) are allowed.
- For non-production environments, please ensure that 208.64.237.133 (for use with IVR re-directs) and 207.245.156.31 and 207.245.156.32 (for use with INT re-directs) are allowed.
- The updated Munis Self Service URLs.
- The updated IVR URLs provided from SaaS Deployment.
- Once Paymentus has received the above information, they will reach out to you directly to confirm and finalize the changes. Once complete, you may attempt to process payments as normal from within Munis and/or the Cashiering application.
Additional Information
- If there are further concerns with payment processing after Paymentus has made the applicable changes, or assistance is needed gathering the above information, please reach out directly, online, through the TSM Support portal.
- Tyler Cashiering v2020.1+ does NOT support integrations with Paymentus. Going forward, a supported payment service for v2020.1+ Cashiering will be required--due to the need for end-to-end encryption. Please see Supported Tyler Cashiering payment vendors for credit card payments for more information.
- To purchase and implement a newer payment service and device, please reach out directly to your sales representative.
- This KCS article is applicable to clients that are on VPN-enabled servers. Please reach out to TSM Support for more information, if you are currently within a VPN-less setup.