How to Clear Menu Cache





Description of Issue

How to clear Munis menu cache



Context
  • Munis

  • Menu



Cause

Sometimes menu cache needs to be cleared if a user is getting the error An error occurred loading this menu after actions such as role or permission changes. 



Resolution
  1. Log into Munis with an account that has System Admin access

  2. From the Tyler menu, open Menu Settings (System Administration > General Administration > Menu Settings)

  3. Select the tab Base Menu Settings

  4. Select Menu Update

  5. There will be a pop up that says: This option will force all users to rebuild their menu, the next time it is run. In addition, the menu cache directory will be cleared. Are you sure you want to force a menu update?

    1. Select Yes



Additional Information
  • This option will force all users to rebuild their menu, the next time it is run. In addition, the menu cache directory will be cleared.

    • This means any pending changes will be pushed to user's menu the next time they reload the menu (Ex: refreshing the page, logging out and back in, refreshing the Menu card, etc.)

  • This is a non-invasive process and is safe to run while users are logged into Munis

  • Clearing menu cache does not delete user's favorites

  • Users may need to refresh their Tyler Menu in Hub for the changes to take effect

    • On the Tyler Menu, click the ellipses in the top right corner

    • Click Refresh