Txmigratbu_migrateProperty error when running initiate bill run





Description of Issue

I get an error when I initiate the new bill run.

Error Message: txmigratbu_migrateProperty: Class code: XXXX, AR category: XX, Type: G not found

Error Message: txmigratbu_migrateProperty: Class code: , AR category: XX, Type: G not found



Context
  • Munis

  • Tax

  • Bill Run



Cause

This issue can have multiple causes.

  1. A parcel or personal property record was created with a class code that does not exist in the class codes program.

  2. A parcel or personal property record was created with no class code and the appropriate class code needs to be added. 



Resolution

Cause 1 Resolution: 

  1. Navigate to Property Revenues > Property Tax Billing > Region > State > Setup > Class Codes

  2. Add a new record.

  3. Fill in the Class Code, AR category, and Property Type from the error message.

    • G - General

    • L - Land

    • B - Building

    • P - Personal

  4. Click Accept to save changes. 

Cause 2 Resolution: 

  1. Navigate to appropriate program for Real Estate or Personal Property

    1. Personal Property: Property Revenues > Property Tax Billing > Region > State > Properties > Personal Property

    2. Real Estate: Property Revenues > Property Tax Billing > Region > State > Properties > Parcels

  2. Search for records.

  3. Under the Location heading (bottom left), click to the Class Code box.

  4. Enter <0 in the class code box.

  5. Click Accept to search for any records with a blank class code. 



Additional Information