Users unable to view payroll data in SQL





Description of Issue

Some users are unable to see any rows in SQL when doing a select script for the pr_employee_master table. 



Context
  • Payroll

  • Roles

  • Tyler Reporting Service Views 

  • User Attributes

  • SQL



Cause

Users did not have a Tyler Reporting Service Views record or a User Attribute Record with a Role providing Data Access. 



Resolution

Munis Version 11.3

  1. Go to User Attributes. (System Administration>Security>User Attributes)

  2. Search for the User. Click Accept. 

  3. On the Roles tab, click Add at the bottom. 

  4. Define Role(s) required for Data Access. Click Accept. 

  5. Go to Tyler Reporting Service Views (Report Writer>Tyler Reporting Service Views)

  6. Search for the User. If the user does not have a record, one will need to be added. 

    1. Click Add. Define User ID and check the checkbox next to Payroll. Click Accept. 

Munis Version 2018.1 and higher

  1. Go to User Attributes. (System Administration>Security>User Attributes)

  2. Search for the User. Click Accept. 

  3. On the Roles tab click the Role that grants Munis System access. 

  4. Click Edit Role. 

  5. Click the Munis System Folder. 

  6. Scroll to the bottom under Data Access, note Reporting Views Access.

    1. Click Update and update access as necessary. 



Additional Information