Update Crystal Report to use new ODBC connection

Description of Issue

Custom Reports not working after an upgrade

Context
  • Crystal Report

  • ODBC

  • Munis All Versions

  • Self Hosted

  • On-Prem

Cause

Tables/views in the report are not updated to use the new ODBC connection

Resolution

After creating the new ODBC connection, open the Crystal Report application and the report.

  1. Click on Database in the top menu.

  2. Click on Set DataSource Location.

  3. In the bottom panel that says Replace With: Expand Create New Connection Folder

  4. Expand ODBC(RDO) folder.

  5. In the popup window, Click once on the new ODBC connection

  6. Click Next

  7. Check off the Trusted Connection check box and click finish.

We have to update each table/view(top panel) to point to the view/table in the new connection(bottom panel) we just created.

  1. Click once on the view/table name in the top panel.

  2. Find the same view/table name in the bottom panel and click once.

  3. Click on update.

  4. Repeat steps 1 - 3 for all other views in the top panel

  5. Click Close.

Refresh the report and now the report fetches data using the new ODBC connection. Click Save under File menu to save changes. 

Additional Information

This procedure have to be performed for all other reports. Once saved, the reports will use the new connection going forward.

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