General Billing Print Invoices Not Calculating Interest

Description of Issue

General Billing Print Invoices Not Calculating Interest

Interest not calculating correctly

Interest calculating higher than it should when Printing Invoices 

Context
  • Munis
  • General Billing 
  • Print Invoices
  • AR Effective Date
  • Interest
Cause

In this scenario, Munis users may notice that if interest is applicable to a charge code after printing the General Billing Invoices the interest is either overstated or understated on the physical print out or PDF. Most of the time this is related to the AR Effective Date field not being addressed during the Print Invoices define. This field will retain the last AR Effective Date that was defined and Accepted and will stay here for the user until Reset is chosen during the Print Define which will default all of the fields in the program. 

Resolution

In the General Billing Print Invoices program, click Define to update the last define that was made and confirm the AR Effective Date field is set accordingly to how the Interest should be accrued to. 

Note: If the invoices that are being printed for the second time, update the Print - Run Type from Print to Reprint. 

If the issue persists or another issue presents itself, please submit a case with Munis Support. 

Additional Information