Workflow Pending Approval stuck
Description of Issue
- Unable to locate workflow record
- Approved record still showing pending in approval card
- Workflow action stuck in queue but the transaction is already approved
- Hub shows approval with no record
- Item stuck in approvals list but the workflow does not exist
- Error received when trying to approve or reject older workflow items: Update Error Wfnxtpe3 - The Munis data record represented by this workflow record no longer exists
- Delete Workflow Approval from HUB Card
Context
- System Administration
- Workflow/Approvals
Cause
Typically caused by some disconnect between EERP and the server
Resolution
Before following these steps in PROD it is important to understand what is being deleted. If incorrect items are deleted it will cause issues with other workflow.
Test in a non-PROD environment before updating PROD.
- Navigate to System Administration > Workflow Administration > Pending Actions (Administration Mode)
- Please note that there are two Pending Actions programs in Workflow Administration:
- Pending Actions is inquiry only and this is not the one you want to be using for this process
- Pending Actions (Administration) allows the deletion of records and is the program you should be using for this process
- Please note that there are two Pending Actions programs in Workflow Administration:
- Click Search
- Populate the Process field with the business rule and another unique identifier to pinpoint the bad approval
- Unique Identifier could be the Approver or the transaction number
- Transaction Numbers (requisition, invoice, document etc.) go into the Key Value field with asterisks on either side of it
- Unique Identifier could be the Approver or the transaction number
- Click Accept
- If there are numerous results, click Browse
- Find the bad record and click Accept
- Click Delete
- Click Yes to confirm to delete the bad approval from EERP
- The approval should now be removed from the user(s) pending actions
Additional Information
- Please reach out to the Support team associated with the workflow process type with any additional questions
- Refer to Master Article - Wfnxtpe3 error when releasing workflow for other email workflow issues