/
TouchTime Biometric Reader Not Working

TouchTime Biometric Reader Not Working

Description of Issue

Biometric reader for TouchTime is not providing any prompt when placing finger

Context
  • ExecuTime
  • ET
  • TouchTime
  • Biometric Reader
Cause

Insufficient power via POE

Resolution
  1. Verify that clock is receiving at minimum 30W of power from POE+ capable switch
    • This can be verified by the green light on the back of the device. If it is blinking, it is not receiving adequate power. A solid light would indicate that the device is receiving the required 30W.
  2. Reboot the device by holding the white button on the back
  3. If issue persists and 30W is confirmed, contact support
Additional Information

If issue still persists after POE+ verification, reference Calibrate TouchTime III Biometric Reader





Related content

Calibrate TouchTime III Biometric Reader
Calibrate TouchTime III Biometric Reader
More like this
Calibrate TouchTime II Biometric Reader
Calibrate TouchTime II Biometric Reader
More like this
How to register users fingerprints on TouchTime clocks
How to register users fingerprints on TouchTime clocks
More like this
How to power cycle TouchTime clocks
How to power cycle TouchTime clocks
More like this
Reboot TouchTime III Device
Reboot TouchTime III Device
More like this
Reset TouchTime VII to Re-Register
Reset TouchTime VII to Re-Register
More like this