Advanced ESS Impersonation functionality
Description of Issue
How to add more than one employee number to a single ESS impersonation account.
Context
- Employee Self Service
- ESS
Cause
Sites IT administrator wants to test multiple users ESS functionality using their own account.
Resolution
In addition to the impersonation feature available in ESS using a test user, it is also possible to add more than one employee number to a single ESS account. Once logged in with the account, it is also possible to switch between users without having to log out and log back in.
In order to add a second employee number to an ESS account, take the following steps -Â
- Login to Employee Self Service with your account. This will require your account to have admin access.
- Navigate to Administration > User Administration
- Check Filter results based on User Name, User ID, and Employee ID
- Define your ESS user ID or employee number in the adjacent textbox
- Hit the enter key
- Determine your ESS account from the list that populates and click Edit adjacent to it
- Click the Employee tab on the following screen
- Beneath the textbox displaying your employee number you should see another empty field with the word Add beside it where you will populate the employee number of the employee you would like to impersonate
- Click Add
- Â Scroll to the bottom of the screen and click Update
- Log out of Employee Self Service completely and then log back in
- If you click on the icon in the top right corner of ESS you should now see a dropdown towards the bottom of that icon's dropdown menu. This list will include an entry for whatever Location Code is defined on your Employee Master record, and the Location Code defined on the employee you are impersonating's Employee Master record.
Additional Information
- For more information, see below.
- Please reach out to EERP Human Resources Support with additional questions.Â