Correcting Status Code Misconfiguration

Description of Issue

When attempting to set up workflow by employee the employees are not available to be selected in the list of selection criteria for employees.

Context
  • Tyler Workflow

  • Time & Attendance

  • Employee Profile

  • Employee Master


Cause

 When initial configuration was entered someone created a new status code instead of renaming the existing status code. 

Resolution
  1. Modify initial Status Code created under System Admin > Master File Management > Status Codes

  2. Click pencil to edit

    1. Rename the current active status code called A - Active to All - Active, so that it no longer matches the true name of the status code.

    2. Leave this status code active until the original status code has been updated to A-Active. 

    3. Click Save.

  3. Click pencil icon to edit the Status Code titled Active - Active 

    1. Enter true name (code) for the status 'A'

    2. Enter description of the status code 'Active'

    3. Ensure the active user checkbox is selected

    4. Active flag should default selected and remain selected

    5. Click Save

  4. Once you have updated the status codes, EACH employee will have to be manually assigned to the new status code under System Admin > Master File Management

  5. Select the Edit History for this Entry icon 

  6. Under Save Properties choose

    1. Either Save for a specific pay period may be used if new pay period should only be applied to a specific period

    2. Or Save for whole history and override subsequent changes, starting at to be used when you want to apply changes starting with a date and for every date there after

  7. Select Pay Properties

  8. Update status Code field with newly updated status code

  9. Select General Info

  10. Click Save

Once all employees have been successfully moved to the appropriate status code you can delete or inactivate the status code that had been created in error.

Additional Information

Time & Attendance when initially deployed comes with 3 status codes by default.

  1. Active - Active

  2. Inactive - Inactive

  3. Deleted - Deleted

When integrating Time & Attendance with Enterprise ERP, the Time & Attendance status codes need to be modified or updated to match what is in Enterprise ERP, BEFORE integrating employees.

Time & Attendance Status Code

EERP Status Code

Change Time & Attendance Status Code to

  1. Active - Active

  1. A - Active

  1. A - Active

  2. Inactive - Inactive

  2. I - Inactive

  2. I - Inactive

  3. Deleted - Deleted

  3. T - Terminated

  3. T- Terminated