An invoice is required error in Recurring Invoices

Description of Issue
  • Unable to create Recurring Invoices for the first time.
  • Unable to use 0 as the Recurring ID in Recurring Invoices.
  • Recurring ID in Recurring Invoices is set to 0, which should choose the next available number, and is erroring with the message: An invoice is required.
Context
  • General Billing
  • Recurring Invoices (gbrecurr)
  • Recurring ID
Cause
There are no Recurring Invoice Templates in Recurring Invoices. 
Resolution

In Recurring Invoices, if no prior Recurring Invoice Template has been created, then the program is not able to auto-generate the next Recurring ID at this time. 

Development is currently researching this issue.

In the meantime, as a workaround, add at least one Recurring Invoice Template and manually enter the Recurring ID. After this Recurring Invoice Template is added, 0 can be used when creating subsequent Recurring Invoice Templates. The program will look at the highest Recurring ID in use on a Recurring Invoice Template and add 1 to that number to arrive at the next available Recurring ID. 

Additional Information

Additional resources for working in General Billing's Recurring Invoices program can be found here: Master Article - General Billing Recurring Invoices