New Charge Code Not Appearing In Bill Run

Description of Issue

A charge code was created and added to a service, but it is not appearing in Bill Run.

Context
  • UBCIS

  • Bill Run Process

  • Accounts Receivable Charge Codes

  • Rate Masters

  • Utilities

  • Bill Run Setup

Cause
  • The Charge Code is not Active.

  • The Charge Code year is incorrect.

  • The Bill Run Setup does not allow for the Account/Charge Code to be included.

  • The Account/Charge code is not valid for the Bill Run.

  • The Charge Code Service Date/ Bill Run Date/ New Customer Day makes it invalid

Resolution

Property Revenues > Utility Billing > Setup > Accounts Receivable Charge Codes

  1. Click Search and enter in the Code box enter the Charge Code in question.

    1. If at the bottom of the page No records were found that satisfy the selection criteria occurs then there exists no Charge Code as entered. If desired, use another criteria to search for the Charge Code in question.

      1. If Charge code does not exist, create it.

    2. Confirm the Year of the Charge Code.

      1. If needed Duplicate the Charge Code to the correct year. If multiple, Mass Copy may be used.

    3. Ensure the Category is valid for the Bill Run.

    4. Look for the Active checkbox. If this is not selected:

      1. Select Update

      2.  Check the Active checkbox

      3. Select Accept.

        1. The Mass Active toolbar may be used if multiple Charge Codes need to be set to Active..

    5. In the Toolbar Menu select Rate Master.

      1. Double-click the desired Rate.

      2. Confirm the Effective Date is valid for the attempted run.

Property Revenues > Utility Billing > Master Programs > Utilities

  1. Search for the Account(s) the Charge Code(s) are attached to

    1. If the Charge Code(s) are not attached to the Account(s) use the New Service toolbar option or the New Misc. (if a Misc. Charge Code) to attach the Charge Code(s) the the Account(s).

  2. Confirm the Status, Start Date and Stop Date of the Charge Code(s). The Charge Code Start Date must be before the Bill Start Date in Bill Run Process

Property Revenues > Utility Billing > Setup > Bill Run Setup

  1. Selecting Processing Options, ensure Bill Types and Run Options sections allow for the Charge Code(s) and Account(s) they are attached to to be included in the Bill Run.

  2. Selecting Generate Options ensure the Bill Type, Charge Code and Route allow for the Charge Code(s) and Account(s) to be included in the Bill Run.

  3. Selecting Default Date Options ensure Account Type allows for the Account(s) the Charge Codes are attached to to be included in the Bill Run.

Property Revenues > Utility Billing > Bill Processing > Bill Run Process

  1. Confirm the Run Type and Category Types are correct. Ensure Start Date comes after the Charge Code Start Date. Ensure the Fiscal year and Charge Code year are accurate for the Charge Code(s). 

  2. Select Generate Charges. Confirm the Account Start, Account End, and Processing Ranges section allows for the account and Charge Codes. Take a look to see if any of the checkboxes need to be selected in order to allow the Charge code to be included.

    1. If anything needs to be adjusted, select Define and adjust as needed.

      1. Ensure Execute is selected afterward.

  3. Select Calculate Charges. Select Search and either leave all fields blank or limit the search.

    1. Select Accept.

    2. Ensure the accounts are included in the run. Look to see if the charge codes were included as well.

Property Revenues > Utility Billing > Setup > Settings

  1. Under the Site Info tab, under Billing look at the New Customer Days box. This is the minimum number of service days before a customer may be billed. Ensure the number of days from the day of the Charge Code added to the account and the start of the Billing date are have at least the number of New customer days in-between them. (IE if New customer Days is 15, there must be at least 15 days from the Start Date of the Charge Code (MM/01/YYYY) and the Bill Start Date (MM/15/YYYY)).

  2. If the Charge Codes have not been attached to the Account long enough, they will not appear in this Bill Run, but will in the next.


Additional Information